Welcome, Guest
Username: Password: Remember me

TOPIC: Mavik Thumbnailers spams on our error log

Mavik Thumbnailers spams on our error log 2 years 8 months ago #39

  • sknorr
  • sknorr's Avatar
  • Offline
  • Новый участник
  • Posts: 1
Hi all,

we have been using the free version of Mavik Thumbnailer for a couple of weeks now and a re generally very happy with how well it works. However, we just looked into the servers error log and found lots of entries like this:
[Mon Aug 10 13:36:46.569359 2015] [:error] [pid 1965] [client IP_ADDRESS] PHP Notice:  Undefined offset: 0 in JOOMLA_PATH/libraries/mavik/thumb/generator.php on line 426, referer: OUR_HOMEPAGE_URL
[Mon Aug 10 13:36:46.569365 2015] [:error] [pid 1965] [client IP_ADDRESS] PHP Notice:  Undefined offset: 1 in JOOMLA_PATH/libraries/mavik/thumb/generator.php on line 427, referer: OUR_HOMEPAGE_URL
[Mon Aug 10 13:36:46.569370 2015] [:error] [pid 1965] [client IP_ADDRESS] PHP Notice:  Undefined index: mime in JOOMLA_PATH/libraries/mavik/thumb/generator.php on line 428, referer: OUR_HOMEPAGE_URL
[Mon Aug 10 13:36:46.569396 2015] [:error] [pid 1965] [client IP_ADDRESS] PHP Warning:  Division by zero in JOOMLA_PATH/libraries/mavik/thumb/resizetype/area.php on line 28, referer: OUR_HOMEPAGE_URL
[Mon Aug 10 13:36:46.569405 2015] [:error] [pid 1965] [client IP_ADDRESS] PHP Warning:  Division by zero in JOOMLA_PATH/libraries/mavik/thumb/resizetype/area.php on line 29, referer: OUR_HOMEPAGE_URL
[Mon Aug 10 13:36:46.569689 2015] [:error] [pid 1965] [client IP_ADDRESS] PHP Warning:  strpos(): Empty needle in JOOMLA_PATH/libraries/mavik/thumb/generator.php on line 714, referer: OUR_HOMEPAGE_URL


It also requests images from Google, even though as far as I can tell, we didn't ask Mavik to create thumbnails for external images (the option "Copy images from other servers" is off):
[Mon Aug 10 13:40:00.657855 2015] [:error] [pid 1386] [client IP_ADDRESS] PHP Warning:  getimagesize(https://maps.googleapis.com/maps/api/staticmap?ETC_ETC): failed to open stream: HTTP request failed! HTTP/1.0 400 Bad Request\r\n in JOOMLA_PATH/libraries/mavik/thumb/generator.php on line 403, referer: OUR_CONTACT_PAGE_URL

Apparently, we went over Google's quota there...

This is all mostly FYI. But I guess it would be great if a future version fixed these coding errors.
Thanks,

Stefan.
Last Edit: 2 years 8 months ago by sknorr.
The administrator has disabled public write access.

Mavik Thumbnailers spams on our error log 2 years 8 months ago #41

  • mavik
  • mavik's Avatar
  • Offline
  • Администратор
  • Posts: 124
  • Thank you received: 21
It's not error, it's normal work. Plugin try get image from url but can't so php writes message about it to log.

Option "Copy images from other servers" means that plugin will copy images from other servers to local folder. If this options is off it doesn't mean that plugin won't process these images.

If you want miss some images, you can set class for they and use option Process: except classes.
The administrator has disabled public write access.
Time to create page: 0.204 seconds
Powered by Kunena Forum